Kaiser Willys Jeep Parts
Results 1 to 2 of 2

Thread: Speedometer issue

  1. #1
    Junior Member
    Join Date
    Oct 2016
    Location
    Frisco, TX
    Posts
    1

    Speedometer issue

    In process of buying a nearly, frame-off restored 1949 Willys truck. One small issue is the non-functional speedometer. Current owner states that speedo cable was replaced and appears to be turning from the transmission gear. When connected to the speedometer, needle hardly moves and a grinding sound comes from this gauge. Any ideas? Thanks, all!

  2. #2
    Senior Member LarrBeard's Avatar
    Join Date
    Nov 2014
    Location
    Ft. Wayne, IN
    Posts
    217
    Gee, this sounds familiar..

    The '48 Willys truck had about 250K miles on it and guess what? The speedometer ground and swung wildly!

    There was an instrument cluster on eBay last week or so - with a speedometer in it. I don't think it sold, but it went off.

    Bob's Speedometer Service is good, but he ain't cheap.

    Cable length can be a bit critical.

    To fix it, you'll have to pull the cluster, so get a replacement cable from Auto Zone, cut off a piece, chuck it in a variable speed drill and see how that runs the speedometer. It will tell you definitely just how bad off the speedometer is. There are bushings and stuff in there that wear out. If you feel real lucky, take it apart CAREFULLY and try to lubricate things. Or - there really are times when professional help saves a lot of time and money.

    By the way - there are about four combinations of face plate finish and gauge faces. If you can, post a photo of your combination.

    Let us know what happens!
    Attached Images Attached Images

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •