Results 1 to 4 of 4

Thread: Flat head starts up then cuts off

  1. #1

    Flat head starts up then cuts off

    Having trouble keeping my cj2a running. It will fire up strong then sputter out. I have replaced the points, condenser, rotor, cap, wires plugs and resent the timing.ran great for a couple days then all of a sudden this problem started. It acts like it can't burn the fuel or it stops creating spark. I have watched the point as I turn the engine and seems to create good contact and spark. Am I missing something ? I have spark, fuel and air. Any ideas would be helpful. Thanks

  2. #2
    Junior Member
    Join Date
    Jul 2014
    Location
    Watonga,Ok
    Posts
    10
    Did you forget to tighten the Distributor, maybe it has moved.. Have you rebuilt the carb,,Maybe a jet is clogged.

  3. #3
    I didn't move the disrtibutor in any way. I have reset the points 3 times to top dead center. I think the adjustment screw that ajust the gap for the point is so worn it won't hold. I am going to try a Hot Spark to replace the points and condenser . Has anyone tried this product? Also going to re- wire everything that I have working.( key switch , amp meter and fuel gauge.) hope this fixes my problem and it's not a serious motor issue. Thanks for the reply. Any info helps to narrow down my issues.

  4. #4
    Junior Member
    Join Date
    Jul 2014
    Location
    Watonga,Ok
    Posts
    10
    The Hot Spark is a great replacement for the points. I couldnt with mine because it was the only distributor they didnt make one for so i bought the elecctronic distributor. Bettn money its the carb

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •