Results 1 to 4 of 4

Thread: Ham’s ’48; The Speedometer Saga

  1. #1
    Super Moderator LarrBeard's Avatar
    Join Date
    Nov 2014
    Location
    Ft. Wayne, IN
    Posts
    1,085

    Ham’s ’48; The Speedometer Saga

    Another chapter in the restoration of the ’48 Truck has (hopefully) come to its close.

    When I took the truck out of its two year hibernation back in 1968 to make the trip up to Indiana, the speedometer didn’t work. I recall I had a little cheat sheet taped to the dash to give me an approximate speed estimate – if I took 90 seconds to cover a mile, I was making 40 miles per hour. The speedometer might have worked in the following years before it went into the barn for 35 years, but in my old age I can’t remember.

    When we did the restoration, we sent the whole cluster out to get the gauges and the speedometer overhauled. When things went back together, the speedometer worked for about 10 miles, but the needle started to swing back and forth and then stopped. The odometer worked for a bit longer, but it stopped too. By that time I wanted the truck out of the shop, so the speedometer project got put aside as a “one of these days” project – a not uncommon step in most restorations. I pulled the flex cable out of the housing and went about things. But, the dead speedometer bugged me – a lot!

    Last winter I got under the dash, pulled the speedometer and sent it back to the folks who had overhauled it. They checked it out and said that there was nothing wrong with it. That was good news; at least I hadn’t broken it. I put it back together – another trip under the dash – and nothing worked. But, the speedometer had worked while I had it in the shop when I turned it with my fingers, so I figure something else is happening.

    I crawled under the truck and pulled the end of the speedometer drive cable out of the transmission. The driven gear (15-teeth) was OK, no stripped teeth or wallowed out cable socket. The only thing left was the cable housing. It was time to quit fooling around and get serious. I pulled out the speedometer cable flex housing and measured it – 72-inches. The KWAS catalog has a cable and housing that looked like the one in the 2WD truck – but it was specified as being for a Jeepster and Station Wagons. Trucks and Station Wagons are a lot alike ... I wonder...?

    I called Mike at KWAS and asked him if that cable would fit a 2WD truck. Being the cautious guy he is he said he didn’t think so – it was 64-inches long, a little short. My comment was “If I can’t find 8 inches of slack, I might as well turn in my Jeep card”. The new cable arrived – it took a little hammering to make the retaining clip fit the transmission and some rerouting to make up the 8-inches. (Incidentally, the ’48 Truck Parts Manual calls out a 55-inch cable for 2WD trucks, go figure.) I figured “I’ve got this whipped!”

    Off we went for a test drive. “Rahtsehnfratz!” (That’s West Tennessee made up German for “Aw Shucks”). The odometer turned over very smoothly, but the needle stayed stuck at 0.

    By now the score was; Gremlins 3, Beard 0.

    Let me think about this. On the bench, the speedometer works. Back in the truck, the odometer turns, that means that the cable is working OK. What??? I looked at You Tube. I read some stuff. Then, an idea formed. What if the needle was pinned against the glass? The coupling from the speedometer drive to the needle is through a magnetic clutch arrangement (the speed cup), so pinning the needle would not interfere with the odometer. OK, how do I test this idea? Another trip back under the dash – I’m getting pretty good at this, but it still hurts – and I backed off the mounting screws and pulled the speedometer back from the mounting frame.

    Off for another test drive! By the time I hit the end of the driveway, I knew I had found the problem. The speedometer indicated for the first time since 1968! We drove around for a bit and, as I had remembered, the truck’s happy place is about 43 mph. At 45 it’s starting to strain just a bit.

    So, I got back under the dash (again) and pulled the speedometer out all the way and took it to the shop - again. The needle sits on a shaft coming out of the speed cup (the magnetic drive). It was sitting about 0.200 - inches off the face of the speedometer. I called the speedometer shop and they graciously told me how to get the pointer off the shaft. The shaft is pointed like a sewing needle and the speedometer pointer is a taper fit on that shaft. It would not push on any further, so I decided - no guts, no glory – to just trim the shaft.

    I was able to take about 0.050 off the shaft before I got too close to other things. The pointer does sit noticeably closer to the face now. But, I still wondered if 0.050 was enough? I don’t want to get under that dash again if I can help it – hitting those four blind mounting holes isn’t fun. As a bit of insurance, I decided to add some flat washers to the speedometer flange for some added space. A dab of RTV holds them in place nicely. The flat washers (0.030), the RTV and the trimming probably give me about an added 0.100 of space off the glass. Since I’ve lost the taper fit between the pointer and shaft, I added a wee dab of RTV to hold the pointer in place.

    And, while I was in the neighborhood, I did one more thing. Speedometer and odometer illumination comes from two bulbs mounted in the speedometer housing. There is no light for any gauges but the speedometer. The paint around the bulb housings had yellowed badly, so I put some white enamel around the lamps to get a bit more light on the speedometer and odometer.

    I made one last trip under the dash – that turned into two because I dropped a screw. I twirled the bushing on the back of the speedometer case and .. Yayyyy - the needle moves. It’s off the glass. I screwed the cable fitting into place. We went for a ride and things work fine. Let’s hope they stay that way!

    OK – now, what was the real problem?

    A. A really close inspection of the housing for the cable (the heavy metal, spiral wrapped housing) revealed that there was one place where the spiral had come apart. Could that have put the flex cable in a bind? And, oh by the way – I can find no reference to 72-inch cables for 2WD vehicles. Another Jeep lesson – What you see is what you have.

    B. When the shop rebuilt the speedometer, they replaced the speed cup – the part with the tapered sewing needle shaft. For whatever reason, the shaft was a bit too long, but since they did not have the bezel and glass, they had no way to check for interference.

    The speedometer Gremlins are gone – hopefully finally banished back to Gremlinville. Now, I just have to get the young man next door to help me pull the gas tank so I can calibrate the float and sender to the gauge – another “one of these days” left over projects.
    Attached Images Attached Images
    Last edited by LarrBeard; 04-18-2019 at 09:08 AM. Reason: Added Picture

  2. #2
    Senior Member bmorgil's Avatar
    Join Date
    Dec 2018
    Location
    Northwestern Ohio
    Posts
    307
    Are you happy with the shop? I have the original mechanical water and oil gauges, the ammeter and speedo. All original. I do not know if they work. They defiantly need a clean up. I have heard some shops will charge more than its worth. Whats your thoughts?

  3. #3
    Super Moderator LarrBeard's Avatar
    Join Date
    Nov 2014
    Location
    Ft. Wayne, IN
    Posts
    1,085
    I would not be surprised if restoring the original gauges would cost more than a set of repro gauges. Gauges for the "little Jeeps" are a lot more common than for the early trucks, station wagons and sedan deliveries.

    The shop is "Bob's Speedometer" in Howell Michigan.

    https://www.bobsspeedometer.com/1/120/index.asp


    He's not cheap, but a rebuild was the only choice I had for the '48 truck. I was satisfied - the gauges work and look good.

    Here is a link to a KWAS complete set:

    https://www.kaiserwillys.com/categor...64-cj-2a-3a-3b

    I'll bet the complete repro set is less expensive than rebuilding the originals

  4. #4
    Super Moderator gmwillys's Avatar
    Join Date
    Aug 2017
    Location
    Alabama
    Posts
    1,624
    That is great news!

    As a suggestion, I would look into purchasing a transmission jack at Horrible Freight. I work on everything by myself, (probably because of my sparkling personality) and I use the jack as another set of hands. I've pulled the new style plastic tanks that are found in the newer trucks with no problems. Worth every penny!

    https://www.harborfreight.com/800-lb...ack-60234.html
    Last edited by gmwillys; 04-18-2019 at 12:47 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •