Results 1 to 4 of 4

Thread: 1960 Jeep Wagon in Texas

  1. #1
    Junior Member
    Join Date
    Jan 2021
    Posts
    19

    1960 Jeep Wagon in Texas

    Not sure if there is a way to post in the albums or just do it here. I have been taking photo's along the way when I remember and loading them up to my album when I remember.... added a few more today. Finally got out the two bolts that broke off at the thermostat housing.....going back with grade 8 after reading a couple postings. Thanks. Also posted a couple photos on the tack strip removal, and one of the passenger door with side panel removed. All side panels are now removed, seats and frames removed, wood slats removed. Using Ospho to treat some rusty areas in the cargo floor and cab. Replaced master cylinder, brake lines, and replacing wheel cylinders next. Have not decided on Dot 3 or to use the Dot 5 synthetic yet. Sounds like the Dot 5 might be the way to go since it is a new system, but Dot 3 would probably be fine for my needs. I will try to keep posting as I go. Thanks!

  2. #2
    Super Moderator bmorgil's Avatar
    Join Date
    Dec 2018
    Location
    Northwestern Ohio
    Posts
    1,943
    Pictures are much appreciated! It sounds like you are well on your way now.

  3. #3
    Super Moderator gmwillys's Avatar
    Join Date
    Aug 2017
    Location
    Alabama
    Posts
    2,758
    Well done on the broken bolt removal. Your pictures are great as well!

  4. #4
    Senior Member 5JeepsAz's Avatar
    Join Date
    Aug 2019
    Posts
    521
    Love the pics!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •