Results 1 to 10 of 86

Thread: My horn is still great... but my carburetor isn't!

Threaded View

  1. #1
    Member Mark J's Avatar
    Join Date
    Aug 2014
    Location
    Costa Mesa, California
    Posts
    81

    My horn is still great... but my carburetor isn't!

    Hello all
    I thought of adding this to my combination "what to do with brake shoes" and my horn-related posts (whoops almost said "horny") but decided to create a new thread.

    Back when I got my 3B to run, I had added that India-made Solix style carburetor. It's been running but never too great and always ran rich. Now I've got a horrible backfiring problem. It's so bad it just won't run at all. I've checked EVERYTHING and I'm running out of possibilities, at least within my knowledge base in my faltering brain.
    I've not been too happy with it so I decided to rebuilt my Carter carburetor just to rule things out.
    It was fairly straightforward and I bought a rebuilt kit made by Walker Products. It came with two small black seals that only can go on the accelerator pump linkage, the flat rod that goes down into through the bowl. One was thin, and one was THICK! I have no clue what these were for... dust protection?? Both my old Carters didn't have it. I put in the small one. Does anyone know if these were necessary and if I used the correct one?
    Mark
    Attached Images Attached Images

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •