Results 1 to 10 of 10

Thread: 48 - CJ2A Fuel Pump Issues

Threaded View

  1. #1
    Junior Member
    Join Date
    Sep 2021
    Location
    Minnesota
    Posts
    22

    48 - CJ2A Fuel Pump Issues

    Hi,
    New member here and I have posted an introductory in the NEW MEMBER section.

    I purchased a CJ2A which seems to be in relatively OK condition (remains to be seen as I dive into it) and am working on getting it started. Previous owner said her dad used up until 2016, at which point he passed away. For the most part is has been sitting in her garage and her brothers started and ran it about once a year (thanksgiving)

    They obviously had fuel pump issues as a new fuel pump came with the purchase of the Jeep.

    As it turns out the old fuel pump was in the box and that fuel pump was already installed on the jeep.

    So at first, I worked on getting the engine popped off. Did not want it to run long as the age of the gas in the vehicle and the condition of the fuel tank was unknown.

    1) I bought a battery, hooked it up and engine spun over nicely.
    2) poured a small amount of fresh gas in carb along with starting fluid and engine fired and Backfired a little. Seemed missing on some cylinders.
    3) Checked out some basic things and found spark plug wires loose on the plugs, and more importantly loose in the distributer cap. reseated plug wires and cleaned distributer connections and pushed them back into the distributer until they clicked in place.
    4) Repeated step 2, and she fired off better, I was even able to rev it slightly by pressing accelerator pedal, but then it died when fuel in carb was depleted.
    5) I disconnected fuel line to fuel pump and connected an auxiliary tank with fresh fuel. I could not get the vehicle to run any better than above. Just died when fuel I poured in carb was burned up.
    6) I disconnected the fuel pump outlet and placed it in an empty gas can. I removed spark plugs ( so engine turns easy) Turned engine over and no fuel was pumping from the fuel pump. I found this odd as fuel pump was relatively new.
    7) I ordered a brand new fuel pump from Kaiser. Came within a couple days. I put the new pump on the jeep and repeated step 6 with input fuel from an auxiliary tank and output goin got an empty gas can. Still no fuel is being pumped by the brand new fuel pump. I am a little stumped at this point.


    Its almost like the fuel pump actuator arm is not being pushed, Is that Possible?

    My research came up with a FUEL PUMP SPACER, but I do not think mine has one. Is this required? The part right up in Kaiser sight says it is essential, however if I need it, I do not think the bolts on the fuel pump will be long enough.

    Looking for recommendations on what to check next, This seems like a very simple system, and I was shocked that putting a new pump on did not pump gas.

    NOTE - I did try priming the pump, and fuel flowed right through. ( the auxillary fuel tank was higher than the output tank. When I put the auxillary tank at about the level of the original fuel tank and the output at the height of the carb, fuel did not run through to the output . However when I cranked the engine, no fuel was pumped (The glass bowl basically remained empty except for a small amount of fuel that was there from priming it)

    What should I try next?

    PS: I read a different forum post where someone was running their fuel pump without a spacer and was getting the fuel pressure of 4 which is the recommended pressure.
    Last edited by jeep_n_john; 09-24-2021 at 07:14 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •